57
[FIX] Wrong Pin/Pattern when restoring TWRP Nandroid Backup

  1. Icebird00 Gingerbread Dec 29, 2016

    Icebird00, Dec 29, 2016 :
    Hi thanks it works great. First i don't see the folder/files, but after mounting data/cache they are there. just had to rename the locksettings* to get around my pattern lock.
     

    #21
  2. G_Luis_Barba_uPCh Cupcake Jan 6, 2017

    G_Luis_Barba_uPCh, Jan 6, 2017 :
    How can you delete these files via adb. I am locked out of my twrp, because it asks for some password. I've tried my lockscreen passcode, but its refusing to unlock. Pls help
     

    #22
  3. jansvanda Honeycomb Jan 9, 2017


    #23
  4. Bernie55 Cupcake Mar 10, 2017

    Bernie55, Mar 10, 2017 :
    Fantastic, Thanks! I was pretty disappointed when I couldn't use my backup and had to set the phone up again.
     

    #24
  5. Manikandan Cupcake Mar 24, 2017


    #25
  6. manoj Eclair Apr 4, 2017

    manoj, Apr 4, 2017 :
    TWRP not giving access to storage, asking for password which i didnt set.
    I removed the files using ROMTOOLBOX LITE
    because TWRP not giving access.
    but it is not woking.
     

    #26
  7. mbakshi Cupcake Apr 6, 2017


    #27
  8. snowcat98 Eclair Apr 9, 2017

    Attached Files:

    Last edited: Apr 15, 2017

    #28
    iCoerce likes this.
  9. gabrielmm Cupcake Apr 15, 2017

    gabrielmm, Apr 15, 2017 :
    Perfect Thank you! what worked for me was only deleting the gatekeeper.pattern.key (only that file)! fingerprint was working fine! if you have twrp you can use the file manager from it too to delete, easy and simple.
    Edit, I have to delete locksettings.db too. otherwise security options in android crashes.
     
    Last edited: Apr 15, 2017

    #29
  10. iCoerce Donut Apr 18, 2017

    iCoerce, Apr 18, 2017 :
    absolute life-saver bro... you just made every backup I've ever had so easy... not all heroes Wear capes
     

    #30
    snowcat98 likes this.
  11. iCoerce Donut Apr 18, 2017


    #31
  12. hanschristianandersen Cupcake Jul 16, 2017


    #32
  13. DaniFilth84 Cupcake Aug 3, 2017

    DaniFilth84, Aug 3, 2017 :

    Thank you very much my friend, you saved me a few days of restoring everything.
    Cheers.
     

    #33
  14. Math. Cupcake Aug 13, 2017


    #34
  15. v0 HaVoK 0v Honeycomb Sep 2, 2017

    v0 HaVoK 0v, Sep 2, 2017 :
    For the OnePlus 5 does this happen also? Was trying to see if anybody talks about it for op5 but can't find a thread anywhere.
    If it does happen. Can you stop this from happening by removing your lock and fingerprint before making the backup?
     

    #35
  16. F_Andrea_Ippolito_ZsRS Ice Cream Sandwich Sep 14, 2017

    F_Andrea_Ippolito_ZsRS, Sep 14, 2017 :
    Bonus tip: I had to follow this procedure a couple of times already (when coming back to OOS after trying LOS and AOSPA).
    The 1st time I found most of those files and delete them, but I had to re-train my OP3 with my 4 fingerprints, which is a bit time consuming.
    This time, after AOSPA, I could only find the locksettings* files (I didn't register any fingerprints on AOSPA, though, so I guess that's why I didn't have password/pattern key files).
    Anyway, by deleting only the locksettings files and restoring my OOS backup, I was able to find my previously stored 4 fingerprints in the settings.
    I just had to choose again the unlock method, from swipe to sequence, and register my sequence again. But after that, both sequence and fingerprint unlock went back to normal, without having to re-register fingerprints.

    Cool!
     

    #36
  17. dblaster Honeycomb Sep 20, 2017 at 12:32 AM


    #37