0
Camera autofocus clicking sound in video

  1. jshq97 Gingerbread Jan 21, 2015

    jshq97, Jan 21, 2015 :
    Hi, I was wondering if anyone else has the issue of clicking noises being recorded by the microphone when the camera auto focuses in video. It seems as though the sound is coming from a vicious autofocus motor that is making the lenses snap back and forth creating a sound whenever the camera refocuses.

    This happens with any autofocus mode when the camera focuses while recording video.

    (this is a different issue to the classic rattling sound that the lenses make when the phone is shaken.)

    I am using the stock app that is built into CM11S

    I would be really grateful if anyone has any advice on this :)
     

    #1
  2. 0mnomnom Jelly Bean Jan 21, 2015

    0mnomnom, Jan 21, 2015 :
    Haven't experienced this on mine.. I'd say you're absolutely correct in it being the motor. Not sure why it would be loud enough to affect the video other than a hardware fault. Any camera app would do the same thing.
     

    #2
  3. jshq97 Gingerbread Jan 21, 2015

    jshq97, Jan 21, 2015 :
    May I ask if you use continuous focus or auto?

    When my camera refocuses it seems to totally refocus then focus on the image. This leads me to thing it may be a buggy release of the OTA update that is making it behave erratically.
     

    #3
    0mnomnom likes this.
  4. 0mnomnom Jelly Bean Jan 22, 2015

    0mnomnom, Jan 22, 2015 :
    Yes I do notice mine constantly refocus while video recording. Pretty annoying and I agree that part has to be software, but the lense motor shouldn't really make noise audible in the recording. I'll check again in a few minutes (my OPO is not my main phone) and let you know if I hear motor noise on mine.
     

    #4
    jshq97 likes this.
  5. jshq97 Gingerbread Jan 22, 2015

    jshq97, Jan 22, 2015 :
    Cool, thanks. I actually switch between my OPO and my 5S but prefer Android to iOS, the 5S camera gives the OPO a run for its money when recording 1080p, but in DCI 4k there's no match :)
     

    #5
  6. 0mnomnom Jelly Bean Jan 22, 2015

    0mnomnom, Jan 22, 2015 :
    So I tested mine and mine doesn't make any noise at all. Even put my ear on it while tapping the screen to manually refocus it.
     

    #6
    jshq97 likes this.
  7. jshq97 Gingerbread Jan 22, 2015

    jshq97, Jan 22, 2015 :
    I'm really confused lol. I have a feeling that it is a software issue because when the camera autofocuses it seems to fully defocus the image the refocus instead of just a smooth action like other smartphones and cameras. This actually my second OPO 64gb sandstone, and the problem seems to be more prominent since the 44s update.
     

    #7
  8. Hana88 Honeycomb Jan 22, 2015

    Hana88, Jan 22, 2015 :
    I have this problem too and i think it's a hardware problemi that effect all the opo.
    This is my second opo and all of them have this problem
     

    #8
    wedad likes this.
  9. jshq97 Gingerbread Jan 22, 2015

    jshq97, Jan 22, 2015 :
    I think this could be fixed with software updates as it seems that the autofocus motor is being powered too quickly causeibg it to snap back and forth with might also explain the hunting for focus issue. It could also be that there is a glitch or something with the audio recording where it is recording audio from the rear mic that is close to the camera lens, since the OPO mics are so sensitive I wouldn't be surpied if it was just picking up the sound because it is so close to the camera on the logic board
     

    #9
    ElectricPulze and Hana88 like this.
  10. ElectricPulze Honeycomb Jan 31, 2015


    #10
    wedad likes this.
  11. jshq97 Gingerbread Jan 31, 2015

    jshq97, Jan 31, 2015 :
    I can confirm this is a hardware issue, I have taken apart my phone to inspect the camera module, I have just ordered two replacement P13N05A modules to replace it, hopefully those don't have faulty AF motors as well.
     

    #11
  12. ElectricPulze Honeycomb Jan 31, 2015

    ElectricPulze, Jan 31, 2015 :
    Do you think it's possible to find a camera module with image stabilization?
     

    #12
  13. jshq97 Gingerbread Jan 31, 2015

    jshq97, Jan 31, 2015 :
    I don't think it is possible as even the P13N05B module which is identically spec'd has a totally different pin out arrangement, the supplier I found seems to be the only commercial one in the world that provides the P13N05A modules.
     

    #13
  14. hydelicious Cupcake Feb 2, 2015

    hydelicious, Feb 2, 2015 :
    Not to doubt you, but how do you know it's a hardware issue? I've been contacting support about this issue and they recently sent me this:

    "Please don't worry.
    This is not a quality issue.
    The sound is because the camera need to move to get a focus.
    The two cameras in our device can move automatically and there will be some small sound of such a movement:)"
     

    #14
  15. AAB4K Jelly Bean Feb 2, 2015

    AAB4K, Feb 2, 2015 :
    Video sample?
     

    #15
    OPOALEX50 likes this.
  16. ElectricPulze Honeycomb Feb 2, 2015


    #16
    jshq97 likes this.
  17. AAB4K Jelly Bean Feb 2, 2015

    AAB4K, Feb 2, 2015 :
    That is normal. My phone also makes that noise. Its the lens trying to focus...
     

    #17
  18. OPOALEX50 Eclair Feb 3, 2015


    #18
  19. Encho Honeycomb Feb 3, 2015


    #19
  20. ElectricPulze Honeycomb Feb 3, 2015

    ElectricPulze, Feb 3, 2015 :
    I know, but it's annoying and when you record video in snapchat, it never focuses... Constantly trying to focus.
     

    #20
    AAB4K likes this.