OxygenOS Bluetooth headphones' commands like play/pause and previous/next song don't always work

  1. Flamecrest Cupcake Mar 14, 2018 at 11:44 AM

    Flamecrest, Mar 14, 2018 at 11:44 AM :
    I got a Sony WH-H900N recently, and I'm loving it. The only downside that I'm experiencing is that the pause/play function (double-tapping on the right 'ear') and previous/next song function (swiping left and right on the right 'ear') don't work properly. With that I mean that I'm hearing a beep in my ear, notifying me that the gesture has been registered, but then my phone doesn't respond to that command.

    This only happens sometimes, but it's seemingly random when it does and doesn't work. In thesame 'pairing session' (for the lack of a better word), it either works 100% of the time or it doesn't work 100% of the time. It can go well for days, and then not work for a day, then work again for a day and not work for days on end.

    I've traded the headset for a newer one (still WH-H900N), and it has thesame issues, which has led me to believe that this is not an issue with the headset, but with the phone or the OS. A friend of mine suggested that it might be because of Bluetooth drivers.

    Has anyone had thesame issues, or does anyone know the solution to this?

  2. sionek Cupcake Mar 14, 2018 at 11:54 AM

  3. atulclassic Honeycomb Mar 14, 2018 at 11:58 AM

  4. Flamecrest Cupcake Mar 14, 2018 at 12:28 PM

    Flamecrest, Mar 14, 2018 at 12:28 PM :
    Friend of mine explained this to me more in-depth. I hope I'm explaining this correctly.
    Apparently there's a kind of standard for Bluetooth that most (if not all) manufacturers follow, which is like the basic functionality support for devices. But it appears that startups and lesser experienced companies (which OnePlus is, let's be honest) have more trouble integrating these standards in their products. So it could be that either OxygenOS or OnePlus 5T insufficiently adheres to those standards.

    I'm gonna post a bug report, and I think it would help if you two did so aswell.
    Here's to hoping for a reply from OnePlus staff, or at least an acknowledgement that this is an issue.

  5. drhide2020 Cupcake Mar 14, 2018 at 5:46 PM

  6. atulclassic Honeycomb Mar 15, 2018 at 6:31 AM

    atulclassic, Mar 15, 2018 at 6:31 AM :
    If that would be the case, it wouldn't have worked previously in Oxygen OS 4 or Nougat

  7. Flamecrest Cupcake Mar 15, 2018 at 10:38 AM

    Flamecrest, Mar 15, 2018 at 10:38 AM :
    Yeah someone on Reddit said that this is an issue with the current OOS. As soon as the next OOS comes out, it'll be fixed. I guess I'll just suffer through, because I don't feel like rooting my phone to install another ROM based on android 8.1